Question

Cannot connect to a port over the internet (works from localhost)

  • Posted on January 17, 2015
  • davidhqAsked by davidhq

I’m running something on port 9292:

david@theta:~$ lsof -ni tcp:9292
COMMAND  PID  USER   FD   TYPE     DEVICE SIZE/OFF NODE NAME
ruby    2406 david   13u  IPv4 1579461398      0t0  TCP 127.0.0.1:9292 (LISTEN)

david@theta:~$ telnet localhost 9292
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

The problem is that from elsewhere I cannot react it:

david@eclipse:~$ telnet 188.226.243.223 9292
Trying 188.226.243.223...
telnet: connect to address 188.226.243.223: Connection refused

Port 80 works:

david@eclipse:~$ telnet 188.226.243.223 80
Trying 188.226.243.223...
Connected to 188.226.243.223.
Escape character is '^]'.

I’m not using any firewalls.

What else can I try?

Thank you, David


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

How can I make it listen to outside connections as well?

I’m using Faye:

faye_server = Faye::RackAdapter.new(mount: '/faye', timeout: 45)

but I haven’t changed anything … before it worked… not sure if there is a special option to bind it ‘globally’… are you sure that lsof says it can be used exclusivelly on localhost?

As you can see in your lsof output, it’s bound to 127.0.0.1.