Cannot connect to ftp through FileZilla

Posted June 29, 2013 48k views
I just followed the instruction of this link to install a vsftpd: I then: chown root:root /home/reddit because /reddit/ is the folder I want to have access to through ftp When I connect through putty, it says Connected to 220 (vsFTPd 2.3.5) Name ( But when I do it through filezilla I get that the password is incorrect. I'm using my root account. PS: sorry for posting too many topics but I'm new to this and I'm trying to set up my project.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
15 answers
I added a new user with a new password but I'm still getting the same error.
It won't work.

I installed vsftpd correctly. I added a new user, I changed /usr/sbin/visudo and I added the new user with root privileges inside. I gave the new user access to its own folder under /home/username

even though I wanna access /home/reddit/ and not /home/username/

But it would still not connect in FileZilla

doesnt work for me

judts cant connect with filezilla.

Even I cant connect through SFTP also

EDIT: this is the error I get on FileZilla

Response: 530 Login incorrect.
Error: Critical error
Error: Could not connect to server
You can't login as root. You have to create a new user:
by Etel Sverdlov
This tutorial covers the basic commands to add, grant permissions to, and delete users. It is written for both CentOS and Ubuntu.
This is the error I'm getting

Response: 500 OOPS: vsftpd: refusing to run with writable root inside chroot()

Follow what it says in the last bit of the second section (where it starts with "Because of a recent vsftpd upgrade").
by Etel Sverdlov
Vsftpd is a fast and secure FTP server. Installing an FTP server can assist you with uploading files to your droplet. This tutorial describes how to install and set up vsftpd on Ubuntu 12.04.
I think it worked. I am now being able to enter /files/ inside /home/username/files via FileZilla to upload/download files.

But I originally wanted access to /home/reddit/ so I can upload files to my site.
EDIT: I fixed it. Turns out all I needed to do was create a new user with the name 'reddit' and it was done.
Previous 1 2 Next