Cannot connect to ftp through FileZilla

  • Posted June 29, 2013

I just followed the instruction of this link to install a vsftpd:

I then: chown root:root /home/reddit because /reddit/ is the folder I want to have access to through ftp

When I connect through putty, it says Connected to 220 (vsFTPd 2.3.5) Name (

But when I do it through filezilla I get that the password is incorrect. I’m using my root account.

PS: sorry for posting too many topics but I’m new to this and I’m trying to set up my project.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Even I cant connect through SFTP also

doesnt work for me

judts cant connect with filezilla.

It won’t work. <br> <br>I installed vsftpd correctly. I added a new user, I changed /usr/sbin/visudo and I added the new user with root privileges inside. I gave the new user access to its own folder under /home/username <br> <br>even though I wanna access /home/reddit/ and not /home/username/ <br> <br>But it would still not connect in FileZilla

I added a new user with a new password but I’m still getting the same error.

Is sftp instal ed by default with digital ocean !?? For any droplet ??

So why it doesn’t work??

run sudo nano /etc/vsftpd.conf

add the following line


restart ftp

sudo service vsftpd restart

Finally after some hours:

I created users using useradd, and those doesn’t work… i delete it and create again with adduser… it works!!!

To me also the same problem.

I cannot connect through FTP, 3 days ago i bought and added droplet on digitalocean. Now still waiting for solution how to connect through FTP. I have posted this on support, but for 2 days there is no response even.

I feels!!

The solution for this case is really simple. After install and configure the vsftpd (, follow the steps bellow:

1 - Create an user:

sudo adduser youruser

It will create an folder inside the root /home folder. 2 - Own its folder for root:

sudo chown root:root /home/youruser

3 - Create at least one folder inside its root folder:

sudo mkdir /home/youruser/www

4 - Own the folder to user:

sudo chown -R youruser:youruser /home/youruser/www

5 - Ready! Now you can try to connect via FileZilla or other similar application and transfer files.

Maybe the step 2 is not necessary. Try it. ;)


EDIT: I fixed it. Turns out all I needed to do was create a new user with the name ‘reddit’ and it was done.