Question

Cannot connect to Jetpack ( SIte Inaccessible )

Hey Guys, My name is Frans W. I am a newbie here.

I have issued after i followed the tutorial. Finally, i have reached the wordpress now. But while i want to install Jetpack, there are any issue blocked me. I can install it, but when i want to connect it, the top is showing error message:

Your website needs to be publicly accessible to use Jetpack: site_inaccessible

Error Details: The Jetpack server was unable to communicate with your site https://tenpotech.com [IXR -32300: transport error: http_request_failed SSL certificate problem: unable to get local issuer certificate]

My Following Block is like that,

server { listen 443 default_server; listen [::]:443 default_server ipv6only=on;

    root /var/www/web/html;
    index index.php index.html index.htm;

    server_name tenpotech.com www.tenpotech.com;

ssl on;
ssl_certificate /var/www/web/cert/tenpotech.com.crt;
ssl_certificate_key /var/www/web/cert/tenpotech.com.key;

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_ciphers 'EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH';

    location / {
            # try_files $uri $uri/ =404;
            try_files $uri $uri/ /index.php?q=$uri&$args;
    }

    error_page 404 /404.html;

    error_page 500 502 503 504 /50x.html;
    location = /50x.html {
            root /usr/share/nginx/html;
    }

    location ~ \.php$ {
            try_files $uri =404;
            fastcgi_split_path_info ^(.+\.php)(/.+)$;
            fastcgi_pass unix:/var/run/php5-fpm.sock;
            fastcgi_index index.php;
            include fastcgi_params;
    }

}

server { listen 80; listen [::]:80; server_name tenpotech.com www.tenpotech.com; return 301 https://$server_name$request_uri; }

Am i missing something? Any advice for that? Need your help.

Thank you, Frans W


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello frans, tbh i am not going into deep with this but when this error happens with my blog I searched a lot on internet. I finally found a solution that any change to .htacess file will leads to site_inaccessible. However the easy way to solve is to disable any security related plugin or restricting any module to make change in it. In short checout this blog post to solve site_inaccessible jetpack issue.

The error you are seeing is returned when Curl (the process being used by php to connect) is unable to verify the certificate for your SSL site. Jetpack will not be able to connect back to your WordPress instance if it is not able to verify your certificate. After some searching, this post may have a workaround. You can also look into setting up a proper verifiable SSL certificate for free from LetsEncrypt to resolve this.