Question

Cannot connect to VPN server after ~47 connections.

Hi, I have configured a vpn server using this tutorial: link

Everything works fine till the moment I reach around 47 clients connected then suddenly no more clients are allowed to connect and what is more my server every time someone tries to connect creates new pppd process.

Since our clients try to reconnect every 5 minutes if no vpn connections there is a problem with RAM consumption.

Did anyone have similar problem? Thanks in advanced


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I checked max clients (default value is 100 - changed it to 2000). Remoteip settings looks like that: 172.16.0.2-254,172.16.1.2-254,172.16.2.2-254,172.16.3.2-254 So this shouldn’t be a problem.

Log for single client looks like that:

Nov 29 10:18:09 DeimicVPN pptpd[3705]: CTRL: Client xx.xx.xx.xx control connection started
Nov 29 10:18:10 DeimicVPN pptpd[3705]: CTRL: Starting call (launching pppd, opening GRE)
Nov 29 10:18:10 DeimicVPN pppd[3706]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
Nov 29 10:18:10 DeimicVPN pppd[3706]: pptpd-logwtmp: $Version$
Nov 29 10:18:10 DeimicVPN pppd[3706]: pppd 2.4.6 started by root, uid 0
Nov 29 10:18:10 DeimicVPN pppd[3706]: using channel 181
Nov 29 10:18:41 DeimicVPN pptpd[3705]: CTRL: Reaping child PPP[3706]

It always takes ~30 seconds to kill the client

EDIT:

lcp-echo-interval 30
lcp-echo-failure 4

Also got this options set in configuration

My first thought was the max clients setting and the IP range you’re giving pptp to give out to clients. Have you checked both of these settings?

This might also be helpful in enabling some debugging logs to start looking for why the new connections aren’t accepted after you reach 47.