Question

Cannot enable inbound HTTP traffic to my droplet

Hi,

Recently I attached a new domain to my droplet (currently there are two attached). Since then, I cannot reach my droplet through HTTP requests on port 80, the result is always 404 not found.

I tried everything: rules in iptables, setup a firewall in digital ocean UI with enabling rule for HTTP/S.

I tried with nginx, python SimpleHTTPServer module, none of them are reachable.

I cannot tell if the problem arose due to my new domain or not (which BTW has A, CNAME and NS entries), but the SSH(22), K3S(6443) and TCP(8000) ports work, the latter two after I added a rule for them in iptables and firewall.

Probably there’s something wrong with my setup (and not DO’s fault), but this is getting really frustrating because it completely blocks me (cannot create new certificates, cannot test, etc.).

Does anyone have any idea what could have gone wrong? The system inside the droplet is Ubuntu 18.04.1LTS, Linux 4.15.0-88-generic #88-Ubuntu SMP Tue Feb 11 20:11:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux.

Thank you! Alex


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @popescuaf,

The 404 error is related to your website’s vhost configuration rather than your firewall. If you couldn’t open your website via port 80 or 443 you’ve get a connection refused error rather than 404.

Having said that, please make sure to check your vhost configuration and configure it properly. Depending on the WebService you are using, either Nginx or Apache, you can check the following articles how to configure a vhost file

Apache - https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04-quickstart

Nginx - https://www.digitalocean.com/community/tutorials/how-to-set-up-nginx-server-blocks-virtual-hosts-on-ubuntu-16-04

Regards, KDSys