Question

Cannot get domain.com/awstats to run ...

Hi,

DO droplet ubuntu

Installed awstats fine but when trying to load the site URL in the browser then the page returns a 404 error. APC control panel loads fine as well as phpmyadmin will load.

http://www.tuxreports.com/awstats/awstats.pl

Followed this guide to install:

https://help.ubuntu.com/community/AWStats

Is the correct lines to add to the /etc/apache2/sites-available/domain.com file?

Alias /awstatsclasses “/usr/share/awstats/lib/” Alias /awstatsicons/ “/usr/share/awstats/icon/” Alias /awstatscss “/usr/share/doc/awstats/examples/css” ScriptAlias /awstats/ /usr/lib/cgi-bin/ Options ExecCGI -MultiViews +SymLinksIfOwnerMatch

Any ideas?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It most certainly did help! Can’t believe I overlooked it, but the ownership was indeed my cause :(

Yes. Actually, I changed ownership for the files to www-data and now things work, including setting up the area for requiring a user ID and password (.htpasswd). <br> <br>Hopefully this helps the next person struggling to get awstats working.

Read the error: <br> <br><pre>- Did you create your config file ‘awstats.www.tuxreports.com.conf’ ? <br>If not, you can run “awstats_configure.pl” from command line, or create it manually. </pre> <br>The article you linked above says how to properly create that config file. Did you follow that part?