Cannot install Scipy

December 31, 2013 6.5k views
Hi, I am currently unable to install Scipy in my virtualenv. I have tried building via pip, wheels (as per the stack overflow suggestion), and the default package manager, but none of them have worked. My error message is as follows: c++: internal compiler error: Killed (program cc1plus) error: Command "c++ -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -fPIC -D__STDC_FORMAT_MACROS=1 -I/usr/lib/python2.7/dist-packages/numpy/core/include -I/usr/include/python2.7 -c scipy/sparse/sparsetools/csr_wrap.cxx -o build/temp.linux-x86_64-2.7/scipy/sparse/sparsetools/csr_wrap.o" failed with exit status 4 I have the latest version of gcc as well as all of the scipy dependencies, so I am not sure what is causing this problem.
1 comment
2 Answers
I had the same problem, and I believe it's because the scipy install runs out of ram. I followed digitalocean's guide to adding a swap file and it worked afterwards:

https://www.digitalocean.com/community/articles/how-to-add-swap-on-ubuntu-12-04

I'd make the swap 1024 megs instead of 512 because I got close to running out.
by Etel Sverdlov
Linux swaps allow a system to harness more memory than was originally physically available. Here's how to set up a linux swap file on Ubuntu 12.04

Yup, the article below (travisirby’s answer) worked for me with the suggested 1024 megs of swap.

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!