Question

cannot load such file -- rubygems/builder

Posted March 7, 2013 6.8k views
I'm following this guide: https://www.digitalocean.com/community/articles/how-to-install-rails-apache-and-mysql-on-ubuntu-with-passenger And am getting cannot load such file -- rubygems/builder when running passenger-install-apache2-module

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

2 answers
The rails ready installer listed here is now installing ruby 2.0.0. Passenger doesn't currently support 2.0.0

To fix this:

rvm uninstall 2.0.0
rvm install 1.9.3-p392

gem install bundler passenger
passenger-install-apache2-module
This was incredibly helpful! I downgraded to 1.9.3-p392 and passenger installed just fine!

Good show, sir!
Submit an Answer