I try to create a simple image called mybusybox_1:v1.0 in DigitalOcean and pull to docker hub. The details are shown as below.

Login Succeeded
# sudo docker push myusername/mybusybox_1:v1.0
The push refers to repository [docker.io/username/mybusybox_1]
097cb51bb7f6: Preparing
514c3a3e64d4: Preparing
denied: requested access to the resource is denied

when I do the same process in my local virtualbox, it work normally. Is there any restriction or limitation in DigitalOcean?

edited by bobbyiliev

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there,

I’ve seen that error in the past when I exceeded the number of private repositories in Docker Hub.

If you also are using private repositories and have gone over the limit of allowed private repositories, I would recommend trying to delete some of the repositories that you do not use so that you could be within the limits.

Then after that try to push the image again.

Regards,
Bobby

  • Thanks for your reply but my docker hub is empty so that I think I still have repository to upload. The point is that it works in my local virtualbox with the same steps but fail in digital ocean.

    • Hello,

      I can confirm that there are no limitations on the server-side. I’ve just tested this with a fresh new Droplet and it works as expected.

      Can you try changing the docker login https://hub.docker.com to docker login docker.io and let me know how it goes?

      Also, note that the username that you’ve logged in with needs to match exactly with the name of the repository that you are trying to push to.

      Regards,
      Bobby

      • thanks for you reply. Event I try to login and specify docker.io but still does not work as below
        REPOSITORY TAG IMAGE ID CREATED SIZE
        dockeruser/mybusybox_1 v1.0 b1ebdf5fe2cd 6 hours ago 1.22MB

        Last login: Tue Aug 18 04:37:29 2020 from 182.239.89.212
        root@kmaster:~# sudo docker login –username=dockeruser docker.io
        Password:
        Login Succeeded
        root@kmaster:~# sudo docker push dockeruser/mybusybox1:v1.0
        The push refers to repository [docker.io/dockeruser/mybusybox
        1]
        097cb51bb7f6: Preparing
        514c3a3e64d4: Preparing
        denied: requested access to the resource is denied

        • Hi there @aidenlai,

          I’ve tried the following:

          • First I created a new Dockerfile:
          • nano Dockerfile
          • And added the following content:
          • FROM busybox
          • COPY ./bobby.sh /bobby.sh
          • Then I created an empty bobby.sh file:
          • touch bobby.sh
          • After that I created a new image:
          • docker build -f Dockerfile -t bobbyiliev/busybox:latest .
          • Then I ran the login command:
          • docker login docker.io
          • I got the following output:
          Authenticating with existing credentials...
          
          Configure a credential helper to remove this warning. See
          https://docs.docker.com/engine/reference/commandline/login/#credentials-store
          
          Login Succeeded
          
          • Finally I pushed the image:
          • docker push docker.io/bobbyiliev/busybox:latest

          The output that I got was:

          The push refers to repository [docker.io/bobbyiliev/busybox]
          1683e44c352c: Pushed
          514c3a3e64d4: Mounted from library/busybox
          latest: digest: sha256:ee4c2da7e2412b0a742ff0adf72da8fc10c62efad0e80ef28524420f87a17709 size: 734
          

          You can even see the image here:

          https://hub.docker.com/repository/docker/bobbyiliev/busybox

          This was all executed on one of my Droplets.

          Regards,
          Bobby

Submit an Answer