Cannot run ghost commands on ghost droplet

I’ve tried all the suggestions in this post:

Steps to reproduce

  1. Deploy a new ghost droplet
  2. ssh into ghost droplet
  3. login as ghost-mgr
  4. cd into ghost project (e.g. /var/www/ghost)
  5. run ghost help

Expected behavior

Ghost command should return list of help instructions.

Actual behavior: When I run ghost help, nothing happens the command just hangs.

Out of ideas on this one. I’m just trying to restart ghost after making a change to default.hbs

I’ve also noticed that my ghost droplet has been ridiculously slow. Taking 20 seconds or so just to load the homepage which has a few static assets, nothing more. Was seeing some 5xx gateway timeout errors intermittently. Monitoring graphs show 99% CPU and Memory usage. Is that normal for the $6/mo tier ghost droplet?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I follow your step and I got same issue.

And then I try this command but still same issue.

$ sudo -i -u ghost-mgr
$ ghost help

Does not return anything. Anyone can help me please?

Site Moderator
Site Moderator badge
October 5, 2022

Hi @jonwt,

Let’s start with the usage question. I believe the minimum RAM for ghost installation is 1GB , (as stated in their documentation) and for lower than 1GB we you use swap memory. Having said that, that can cause some slowness.

A couple of things to check according to GHOST docs again

Are you using the default theme?

The theme is the place where you as a user have the most ability to cause performance bottlenecks by accident, as it were.

Are you up-to-date?

We regularly test and make improvements to performance, so it should pay off to keep up-to-date. If your performance decreases significantly after an update, we’d want to know about it.

Additionally, can you see if you can use the ghost-cli with your root user or you can’t use it with it as well? If that’s the case you can try and install ghost cli on your user by running the following command:

  1. npm install ghost-cli@latest -g


I ssh’d into the droplet and ran reboot. Everything seems to be working now, the slow speeds appear to be gone, and ghost commands are working. Will keep this ticket updated if something changes or goes similarly wrong again.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

card icon
Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Sign up
card icon
Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We’d like to help.

Learn more
card icon
Become a contributor

You get paid; we donate to tech nonprofits.

Learn more
Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow – whether you’re running one virtual machine or ten thousand.

Learn more ->
DigitalOcean Cloud Control Panel
Get started for free

Enter your email to get $200 in credit for your first 60 days with DigitalOcean.

New accounts only. By submitting your email you agree to our Privacy Policy.

© 2023 DigitalOcean, LLC.