Question

Cannot ssh into VM

Since about 8 hours ago I am unable to ssh into my server. This was working fine until it just stopped. I tried to reset the root password and am allowed to reset it. But after I try to login using the new password from the console, the vm will not let me in. I then spun up a new vm from a snapshot of the previous one, this time with ssh key enabled - still no luck. Cannot login even with the ssh key. Any thoughts/ideas would be great.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@cloud6cda1d1f28dea40e13a8c

If you can login from the console make sure the ssh daemon is running with sudo service ssh status if it is not running start it with sudo service ssh start

If you have the firewall enabled make sue to allow ssh incoming connections: ufw allow 22/tcp

Hoe this helps.