Question

Cannot SSH login as non-root user !!!

I am on Ubuntu and using PuTTY to generate SSH keys and connect to the droplet. I can SSH login as root. But not as non-root. This is what i did to SSH login as non-root user:

  1. I manually copied and paste the public key to the file under non-root user
  2. Did the following command for permission:
    chmod 700 .ssh
    chmod 600 .ssh/authorized_keys
    service ssh restart
    

This is the error i got when tried to SSH login as non-root:

Using username "lin-yuan".
Server refused our key
lin-yuan@usorgames.com's password:

The following are what i tried to debug:

  1. I tried lin-yuan@UF:~$ sshd -t and get this:
Could not load host key: /etc/ssh/ssh_host_rsa_key
Could not load host key: /etc/ssh/ssh_host_dsa_key
Could not load host key: /etc/ssh/ssh_host_ecdsa_key
Could not load host key: /etc/ssh/ssh_host_ed25519_key
  1. Then i tried lin-yuan@UF:~$ sudo /usr/sbin/sshd -d and get this:
debug1: sshd version OpenSSH_7.2, OpenSSL 1.0.2g  1 Mar 2016
debug1: private host key #0: ssh-rsa SHA256:+LJlY5iA1DGgr8cGZ2NOtZPT9ATq0gHoQ5YZwFq0TJE
debug1: private host key #1: ssh-dss SHA256:V0ZtT2SCbigpnhFaVRMjmXvo+4JtPUBRnh96L14Aue4
debug1: private host key #2: ecdsa-sha2-nistp256 SHA256:JoKckvTAm13WGE+3KWxROZc9C0SVf40Gn2cxHP6qDeU
debug1: private host key #3: ssh-ed25519 SHA256:lxGynCJlUXTjXsq2jeaVrB7YfiPPpRgcrQlyWPwO7Kc
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-d'
debug1: Set /proc/self/oom_score_adj from 0 to -1000
debug1: Bind to port 22 on 0.0.0.0.
Bind to port 22 on 0.0.0.0 failed: Address already in use.
debug1: Bind to port 22 on ::.
Bind to port 22 on :: failed: Address already in use.
Cannot bind any address.

But i still have no clue where might went wrong, can you help me? I attached the content of my /etc/ssh/sshd_config as below just in case if there are some setting that needs to be changed.

# Package generated configuration file	
# See the sshd_config(5) manpage for details		
# What ports, IPs and protocols we listen for	
Port 22	
# Use these options to restrict which interfaces/protocols sshd will bind to	
#ListenAddress ::	
#ListenAddress 0.0.0.0	
Protocol 2	
# HostKeys for protocol version 2	
HostKey /etc/ssh/ssh_host_rsa_key	
HostKey /etc/ssh/ssh_host_dsa_key	
HostKey /etc/ssh/ssh_host_ecdsa_key	
HostKey /etc/ssh/ssh_host_ed25519_key	
#Privilege Separation is turned on for security	
UsePrivilegeSeparation yes		
# Lifetime and size of ephemeral version 1 server key	
KeyRegenerationInterval 3600	
ServerKeyBits 1024		
# Logging	
SyslogFacility AUTH	
LogLevel INFO		
# Authentication:	
LoginGraceTime 120	
PermitRootLogin yes	
StrictModes yes		
RSAAuthentication yes	
PubkeyAuthentication yes	
#AuthorizedKeysFile	%h/.ssh/authorized_keys	
# Don't read the user's ~/.rhosts and ~/.shosts files	
IgnoreRhosts yes	
# For this to work you will also need host keys in /etc/ssh_known_hosts	
RhostsRSAAuthentication no	
# similar for protocol version 2	
HostbasedAuthentication no	
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication	
#IgnoreUserKnownHosts yes		
# To enable empty passwords, change to yes (NOT RECOMMENDED)	
PermitEmptyPasswords no		
# Change to yes to enable challenge-response passwords (beware issues with	
# some PAM modules and threads)	
ChallengeResponseAuthentication no		
# Change to no to disable tunnelled clear text passwords	
PasswordAuthentication yes		
# Kerberos options	
#KerberosAuthentication no	
#KerberosGetAFSToken no	
#KerberosOrLocalPasswd yes	
#KerberosTicketCleanup yes		
# GSSAPI options	
#GSSAPIAuthentication no	
#GSSAPICleanupCredentials yes		
X11Forwarding yes	
X11DisplayOffset 10	
PrintMotd no	
PrintLastLog yes	
TCPKeepAlive yes	
#UseLogin no		
#MaxStartups 10:30:60	
#Banner /etc/issue.net		
# Allow client to pass locale environment variables	
AcceptEnv LANG LC_*		
Subsystem sftp /usr/lib/openssh/sftp-server		
# Set this to 'yes' to enable PAM authentication, account processing,	
# and session processing. If this is enabled, PAM authentication will	
# be allowed through the ChallengeResponseAuthentication and	
# PasswordAuthentication.  Depending on your PAM configuration,	
# PAM authentication via ChallengeResponseAuthentication may bypass	
# the setting of "PermitRootLogin yes	
# If you just want the PAM account and session checks to run without	
# PAM authentication, then enable this but set PasswordAuthentication	
# and ChallengeResponseAuthentication to 'no'.	
UsePAM yes	

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thank you so much for the detail answer. I tried. But it still doesn’t work. What is the best way to debug SSH issue? what command should i use?

@jasmineyuan2016

When it comes to setting up multi-user SFTP, there’s a little more involved. Setting up an SSH Key for each user is one of those steps, but you also need to modify the configuration a little more and setup a group for these users.

To get started, in the configuration you posted, find this line and comment it out:

Subsystem sftp /usr/lib/openssh/sftp-server

So it should look like the following when commented out.

#Subsystem sftp /usr/lib/openssh/sftp-server

Directly below that line add the following:

Subsystem sftp internal-sftp
    Match group sftpusers
    ChrootDirectory %h
    X11Forwarding no
    AllowTcpForwarding no
    ForceCommand internal-sftp

Hit CTRL + X and save your changes. Now you’ll need to create the group sftpusers:

sudo addgroup sftpusers

Now restart SSH:

service ssh restart

Now that SFTP is setup, you need to make sure that each user is added to the sftpusers group. Any user that isn’t part of this group won’t be able to use SFTP.

To add a user to the sftpusers group:

sudo usermod -g sftpusers username

where username is the username of the user you’re trying to add. It’s also a good idea to make sure the users shell is set to /bin/nologin, and to do that we’d run:

sudo usermod -s /bin/nologin username

where, as above, username is the username of the user you’re modifying.

The last few steps consist of making sure directory permissions are correct and assume that each user resides in /home (i.e. /home/username).

For each user’s home directory, we need to setup proper ownership. To do this, we’ll change the ownership of /home/username to the user and group root:

chown root:root /home/username

Now, directories and files below ./username/ need to be owned by the user themselves and the group needs to be set to sftpusers, so if we created:

/home/username/htdocs

We’d need to change ownership of ./htdocs to the user and our sftp group, like so:

chown username:sftpusers /home/username/htdocs

The same applies to files, so if we have index.php, index2.php, and index3.php in ./htdocs, we need those files to be owned by the same user:group as our directories. To do this, we can run:

chown -R username:sftpusers /home/username/htdocs/

Which recursively changes ownership.