Question

Cant get my domain to load content

I was planning on hosting multiple WordPress sites on my droplet and followed the instructions linked to from https://www.digitalocean.com/community/tutorials/how-to-set-up-multiple-wordpress-sites-on-a-single-ubuntu-vps

I completed the pre-requisites then did a snapshot. I chose not do the 1 click install as I wanted to walk through the setting up of a server as I’ve always used managed hosting thus far.

I create the folders /var/www/brand/domain.com and /var/www/brand/staging.domain.com

I prepared the conf in /etc/apache2/sites-available by copying 000-default.conf and making my edits.

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        ServerName www.domain.com
        ServerAlias domain.com

        ServerAdmin contact@domain.com
        DocumentRoot /var/www/brand/domain.com

        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/brand/domain.com>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

When I go to the root of my domain I get the default Apache page even though the only files in that directory are index.php and info.php both displaying phpinfo() so that I could test before adding in my repo to that folder.

Any ideas on what could have gone wrong? I’m under the impression I have meticulously followed each step.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @ryanpq:

If it is still present I would try removing the 000-default.conf so only your new virtualhost configuration files are present and restart apache again to see if this resolves the problem.

View the original comment