Question

Cant type anything to change the value in php.ini

Posted May 31, 2017 3.6k views
UbuntuApache

I want to change the value in PHP.ini file to below value,

uploadmaxfilesize = 50M
postmaxsize = 50M
maxinputtime = 300
maxexecutiontime = 300

so I run the command in Putty as below
sudo nano /etc/php5/apache2/php.ini

it open the PHP.ini in the console,but when I want to change the value,i just cant type anything.

Please tell me how to type the modify the value in Php.ini file in Putty.thanks..

2 comments

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
3 answers

@matchartproduction

You can add those lines to your php.ini file with these commands ran as root:

   echo "uploadmaxfilesize = 50M" >> /etc/php5/apache2/php.ini
   echo "postmaxsize = 50M" >> /etc/php5/apache2/php.ini
   echo "maxinputtime = 300" >> /etc/php5/apache2/php.ini
   echo "maxexecutiontime = 300" >> /etc/php5/apache2/php.ini
  • Bro i already login as root,run all the command line u gave,and restart the server by
    *sudo service apache2 restart *
    .but the uploadmaxfilesize still the same.didnt update at all

    this is what i see in console.when I recheck the value,please give me some guidance

    http://imgur.com/bYYuYOP

    • @matchartproduction

      Check the end of the php.ini file and you will see the new values.

      Here is no error in the image you posted, from where you are currently type end then type 50M then type CTRL+x then y then enter and your file will be modified and saved, open it again to check.

      Hint: If you are logged in as root no need for sudo, to check if you are logged in as root the output of this command echo $EUID will be zero.

@matchartproduction
Just a question, are you using the numeric keypad or the numbers above the alpha keys?
Try using the numbers instead of the numeric keypad - I’ve seen problems where there is a mixup between PuTTY and the console with some keyboards, so using numeric keypad results in nothing (even when it’s activated, and NumLock is activated right?).

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 64M

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex