Question

Centos 6 is not using the latest kernel installed.

I have a server that has the following kernels installed:

kernel-2.6.32-696.13.2.el6.x86_64
kernel-2.6.32-696.16.1.el6.x86_64
kernel-2.6.32-696.18.7.el6.x86_64
kernel-2.6.32-696.20.1.el6.x86_64

I’m using the DO GrubLoader 0.2 kernel in the control panel, but the server boots with:

2.6.32-696.18.7.el6.x86_64

I’ve changed /etc/grub.conf so it specifies the 20.1 kernel:

#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.32-696.20.1.el6.x86_64)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.32-696.20.1.el6.x86_64 ro root=UUID=59e3d92c-67e1-4cc4-bc90-76123b617391 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet
        initrd /boot/initramfs-2.6.32-696.20.1.el6.x86_64.img

What I am I missing? Why won’t it boot to 2.6.32-696.20.1 or 2.6.32-696.16.1?

Subscribe
Share

We have the same problem.

rpm -q kernel

kernel-2.6.32-431.1.2.0.1.el6.x86_64 kernel-2.6.32-696.20.1.el6.x86_64

I am trying to boot from 2.6.32-696.20.1 but the droplet always boots from 2.6.32-431.1.2.0.1. I have changed the kernel to DigitalOcean GrubLoader v0.2 and powered off the droplet but that did not help. I even added a new entry for the new kernel in /boot/grub/grub.conf but that did no help either.

I am following this howto: https://www.digitalocean.com/community/tutorials/how-to-update-a-digitalocean-server-s-kernel

Any ideas?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi guys,

look at this on superuser.com:

https://superuser.com/questions/1295441/how-do-i-upgrade-my-kernel-in-centos-6-to-the-latest-version

I’ve tried to manually erase the old kernel on a test server and then rebooted, it worked ;)

I’ve also manually deleted the old kernel entry on /etc/grub.conf

So in your case:

rpm --erase kernel-2.6.32-431.1.2.0.1.el6.x86_64

shutdown -r now