blondie63
By:
blondie63

centos 6.x and failed updates

October 24, 2014 8.3k views

Launching yum update iìve this message:

[root@cloud03 ~]# yum update
Loaded plugins: fastestmirror, replace
Loading mirror speeds from cached hostfile
 * base: centos.mirror1.spango.com
 * epel: mirror.nl.leaseweb.net
 * extras: centos.mirror1.spango.com
 * updates: centos.mirror1.spango.com
 * webtatic: uk.repo.webtatic.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-igbinary.x86_64 0:1.1.2-0.5.git3b8ab7e.el6.remi.1 will be updated
---> Package php-pecl-igbinary.x86_64 0:1.2.1-1.el6 will be an update
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-igbinary-1.2.1-1.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-igbinary-1.2.1-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-igbinary-1.2.1-1.el6.x86_64 (epel)
           Requires: php(api) = 20090626
           Installed: php-common-5.5.11-1.el6.remi.x86_64 (@remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-26.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.3.3-27.el6_5.1.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.3.3-27.el6_5.2.x86_64 (updates)
               php(api) = 20090626
           Available: php54w-common-5.4.33-1.w6.x86_64 (webtatic)
               php(api) = 20100412-64
           Available: php54w-common-5.4.34-1.w6.x86_64 (webtatic)
               php(api) = 20100412-64
           Available: php55w-common-5.5.17-1.w6.x86_64 (webtatic)
               php(api) = 20121113-64
           Available: php55w-common-5.5.18-1.w6.x86_64 (webtatic)
               php(api) = 20121113-64
           Available: php56w-common-5.6.1-1.w6.x86_64 (webtatic)
               php(api) = 20131106-64
           Available: php56w-common-5.6.2-1.w6.x86_64 (webtatic)
               php(api) = 20131106-64
Error: Package: php-pecl-igbinary-1.2.1-1.el6.x86_64 (epel)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.5.11-1.el6.remi.x86_64 (@remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-26.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-27.el6_5.1.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-27.el6_5.2.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php54w-common-5.4.33-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20100525-64
           Available: php54w-common-5.4.34-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20100525-64
           Available: php55w-common-5.5.17-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20121212-64
           Available: php55w-common-5.5.18-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20121212-64
           Available: php56w-common-5.6.1-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20131226-64
           Available: php56w-common-5.6.2-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20131226-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Someone can help me ? :)
Thanks

2 comments
  • Bump same exact issue here... can anyone lend some advice to fixing this issue?

  • You are mixing third party repositories. In particular, Remi's repo is notorious for overwriting stock packages with newer packages with the same name. The problem you get into is that EPEL packages are always built against the stock php packages (5.3). Once you overwrite those with Remi's packages (5.5), EPEL php packages such as php-pecl-igbinary are no longer compatible.

    I recommend taking a look at the SafeRepo Initiative. If you need to upgrade to a newer version of php, I recommend using IUS.

2 Answers

You're running into some kind of dependency problem. This is the sort of thing that can occur when you mix different third party repositories. It looks like you have the remi-php55 repo enabled and the PHP package from it installed. Have you tried installing php55-php-pecl-igbinary instead?

[root@123ifix ~]# yum -y install php-mcrypt.x86_64
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile

  • base: mirror.vodien.com
  • epel: mirror.nus.edu.sg
  • extras: mirror.vodien.com
  • updates: mirror.vodien.com Resolving Dependencies --> Running transaction check ---> Package php-mcrypt.x8664 0:5.4.16-3.el7 will be installed --> Processing Dependency: php(zend-abi) = 20100525-64 for package: php-mcrypt-5.4.16-3.el7.x8664 --> Processing Dependency: php(api) = 20100412-64 for package: php-mcrypt-5.4.16-3.el7.x8664 --> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt-5.4.16-3.el7.x8664 --> Running transaction check ---> Package libmcrypt.x8664 0:2.5.8-13.el7 will be installed ---> Package php-mcrypt.x8664 0:5.4.16-3.el7 will be installed --> Processing Dependency: php(zend-abi) = 20100525-64 for package: php-mcrypt-5.4.16-3.el7.x8664 --> Processing Dependency: php(api) = 20100412-64 for package: php-mcrypt-5.4.16-3.el7.x8664 --> Finished Dependency Resolution Error: Package: php-mcrypt-5.4.16-3.el7.x8664 (epel) Requires: php(api) = 20100412-64 Installed: php-common-5.3.3-40.el66.x8664 (@updates) php(api) = 20090626 Available: php-common-5.3.3-38.el6.x8664 (base) php(api) = 20090626 Error: Package: php-mcrypt-5.4.16-3.el7.x8664 (epel) Requires: php(zend-abi) = 20100525-64 Installed: php-common-5.3.3-40.el66.x8664 (@updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-38.el6.x8664 (base) php(zend-abi) = 20090626 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [root@123ifix ~]# yum --enablerepo=remi,remi-php55 update Loaded plugins: fastestmirror Setting up Update Process Loading mirror speeds from cached hostfile
  • base: mirror.vodien.com
  • epel: mirror.nus.edu.sg
  • extras: mirror.vodien.com
  • updates: mirror.vodien.com Resolving Dependencies --> Running transaction check ---> Package curl.x8664 0:7.19.7-40.el66.3 will be updated ---> Package curl.x8664 0:7.19.7-40.el66.4 will be an update ---> Package cyrus-sasl.x8664 0:2.1.23-15.el66.1 will be updated ---> Package cyrus-sasl.x8664 0:2.1.23-15.el66.2 will be an update --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-2.1.23-15.el66.2.x8664 ---> Package cyrus-sasl-lib.x8664 0:2.1.23-15.el66.1 will be updated ---> Package cyrus-sasl-lib.x8664 0:2.1.23-15.el66.2 will be an update --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-lib-2.1.23-15.el66.2.x8664 ---> Package db4.x8664 0:4.7.25-18.el64 will be obsoleted --> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd-tools-2.2.15-39.el6.centos.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-lib-2.1.23-15.el66.2.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd-2.2.15-39.el6.centos.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-4.8.0-38.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: iproute-2.6.32-33.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-libs-4.8.0-38.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: apr-util-1.3.9-3.el60.1.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: pam-1.1.1-20.el6.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: 2:postfix-2.6.6-6.el65.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: 4:perl-5.10.1-136.el66.1.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: python-libs-2.6.6-52.el6.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-python-4.8.0-38.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-2.1.23-15.el66.2.x8664 ---> Package db4-utils.x8664 0:4.7.25-18.el64 will be obsoleted ---> Package device-mapper-multipath.x8664 0:0.4.9-80.el66.2 will be updated ---> Package device-mapper-multipath.x8664 0:0.4.9-80.el66.3 will be an update ---> Package device-mapper-multipath-libs.x8664 0:0.4.9-80.el66.2 will be updated ---> Package device-mapper-multipath-libs.x8664 0:0.4.9-80.el66.3 will be an update ---> Package dracut.noarch 0:004-356.el6 will be updated ---> Package dracut.noarch 0:004-356.el66.1 will be an update ---> Package dracut-kernel.noarch 0:004-356.el6 will be updated ---> Package dracut-kernel.noarch 0:004-356.el66.1 will be an update ---> Package epel-release.noarch 0:7-1 will be updated ---> Package epel-release.noarch 0:7-5 will be an update ---> Package kernel.x8664 0:2.6.32-504.12.2.el6 will be installed ---> Package kernel-firmware.noarch 0:2.6.32-504.3.3.el6 will be updated ---> Package kernel-firmware.noarch 0:2.6.32-504.12.2.el6 will be an update ---> Package kpartx.x8664 0:0.4.9-80.el66.2 will be updated ---> Package kpartx.x8664 0:0.4.9-80.el66.3 will be an update ---> Package libcurl.x8664 0:7.19.7-40.el66.3 will be updated ---> Package libcurl.x8664 0:7.19.7-40.el66.4 will be an update ---> Package libdb4.x8664 0:4.8.30-13.el7 will be obsoleting ---> Package libdb4-utils.x8664 0:4.8.30-13.el7 will be obsoleting ---> Package libssh2.x8664 0:1.4.2-1.el6 will be updated ---> Package libssh2.x8664 0:1.4.2-1.el66.1 will be an update ---> Package nss-softokn.x8664 0:3.14.3-19.el66 will be updated ---> Package nss-softokn.x8664 0:3.14.3-22.el66 will be an update ---> Package nss-softokn-freebl.x8664 0:3.14.3-19.el66 will be updated ---> Package nss-softokn-freebl.x8664 0:3.14.3-22.el66 will be an update ---> Package openssl.x8664 0:1.0.1e-30.el66.5 will be updated ---> Package openssl.x8664 0:1.0.1e-30.el66.7 will be an update ---> Package tzdata.noarch 0:2014j-1.el6 will be updated ---> Package tzdata.noarch 0:2015b-1.el6 will be an update --> Processing Conflict: libdb4-4.8.30-13.el7.x8664 conflicts filesystem < 3 --> Finished Dependency Resolution --> Running transaction check ---> Package cyrus-sasl.x8664 0:2.1.23-15.el66.2 will be an update --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-2.1.23-15.el66.2.x8664 ---> Package cyrus-sasl-lib.x8664 0:2.1.23-15.el66.2 will be an update --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-lib-2.1.23-15.el66.2.x8664 ---> Package db4.x8664 0:4.7.25-18.el64 will be obsoleted --> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd-tools-2.2.15-39.el6.centos.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-lib-2.1.23-15.el66.2.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd-2.2.15-39.el6.centos.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-4.8.0-38.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: iproute-2.6.32-33.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-libs-4.8.0-38.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: apr-util-1.3.9-3.el60.1.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: pam-1.1.1-20.el6.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: 2:postfix-2.6.6-6.el65.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: 4:perl-5.10.1-136.el66.1.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: python-libs-2.6.6-52.el6.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-python-4.8.0-38.el66.x8664 --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-2.1.23-15.el66.2.x8664 ---> Package kernel.x8664 0:2.6.32-431.el6 will be erased --> Processing Conflict: libdb4-4.8.30-13.el7.x8664 conflicts filesystem < 3 --> Finished Dependency Resolution Error: Package: 4:perl-5.10.1-136.el66.1.x8664 (@updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: httpd-2.2.15-39.el6.centos.x8664 (@base) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: httpd-tools-2.2.15-39.el6.centos.x8664 (@base) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: rpm-libs-4.8.0-38.el66.x8664 (@updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: iproute-2.6.32-33.el66.x8664 (@updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: cyrus-sasl-lib-2.1.23-15.el66.2.x8664 (updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: rpm-4.8.0-38.el66.x8664 (@updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: cyrus-sasl-2.1.23-15.el66.2.x8664 (updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: libdb4 conflicts with filesystem-2.4.30-3.el6.x8664 Error: Package: apr-util-1.3.9-3.el60.1.x8664 (@base) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: rpm-python-4.8.0-38.el66.x8664 (@updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: 2:postfix-2.6.6-6.el65.x8664 (@updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: pam-1.1.1-20.el6.x8664 (@base) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found Error: Package: python-libs-2.6.6-52.el6.x8664 (@updates) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el64.x8664 (@anaconda-CentOS-201311272149.x8664/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x8664 (epel) Not found You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest
Have another answer? Share your knowledge.