Question

centos 7 sshd service not found?

Yesterday i installed php,apache,mariaDB all using ssh(putty). Today when i woke up and tried to log-in with putty it said connection established. So i looked it up on the internet. i saw some commands like service sshd restart

And that gave me this error: Failed to issue methode call: Unit sshd.service failed to load: No such file or directory

So it looks like my ssh is just gone? how can i fix this?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

often occur when editing /etc /ssh /sshd_config

This solution did not work for me. Please update with the $ “/bin/systemctl restart sshd” cmd. The RootPassword login no option then worked when doing Step Five — Configure SSH Daemon in Initial Server Setup with CentOS 7.

Hello SynteX, This isn’t a big problem and could probably be fixed simply. If you run

systemctl status sshd.service

It will probably give an output that its disabled. To get this enabled use:

systemctl enable sshd.service

then

systemctl start sshd.service

And then check if its running now:

systemctl status sshd.service 

The output should tell you its enabled. If everything goes well you should have ssh services every time you boot from now on.