Question

CentOS MySQL server won't start

Hey,

I have installed MySQL on my CentOS 7 server, but it won’t start. When i try to start it with the command “sudo service mysqld start” i get the message “Job for mysqld.service failed. See ‘systemctl status mysqld.service’ and ‘journalctl -xn’ for details.” after about 5 minutes.

I have searched Google all day, and just can’t find a solution…

Log: 150111 10:06:40 mysqld_safe A mysqld process already exists 150111 10:20:35 mysqld_safe A mysqld process already exists 150111 10:30:35 mysqld_safe A mysqld process already exists 150111 10:40:35 mysqld_safe A mysqld process already exists

Please help…

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You are running CentOS 7. Run this:

systemctl status mysqld.service

If no errors show up, try this:

systemctl restart mysqld.service

If that fails, run this:

for i in `ps auxf|grep mysqld|grep "grep" -v|awk '{print $2}'`; do kill -9 $i; done

Then, run this:

systemctl start mysqld.service

And finally, to ensure it is working:

systemctl status mysqld.service

Had the same problem. Use command : #sudo tail -f /var/log/messages|grep -i mysql to check if SELinux policy is causing the issue. If so, first check if SELinux policy is enables using command #sestatus. If it shows enabled, than disable it. To disable, i)# vi /etc/sysconfig/selinux ii)change ‘SELINUX=enforcing’ to ‘SELINUX=disabled’ iii)restart linux iv)check with ‘sestatus’ and it should show “disabled”

Uninstall and reinstall mysql. It should be working.

Reinstalling MySQL might help. First uninstall, then delete the /var/lib/mysql and /etc/my.cnf or /etc/my.cnf.rpmsave, then Restart, then Install.