Hi all,

I have been running a plex media server for a few months and it was good till 2 days ago. The server is suddenly offline and disappeared from my account list.

I digged its logs and there are quite a few error entries regarding resolv thing such as:

HTTP error requesting GET httpsXXXXXXXXXX (0, No error) (could not resolv host: plex.tv)
HTTP error requesting GET httpsXXXXXXXXXX (0, No error) (could not resolv host: ocspx.digicert.com)

sudo apt update works fine and the /etc/resolv.conf looks good as it just contains the default system generated name servers.

So just wondering is there anything currently wrong regarding DNS resolving of certain domains, which prevents my server login using my account ?

1 comment
  • I run the plex media server using docker image and I currently use this exactly same configuration and method setup another one running in my laptop and it works perfect. The docker image keeps latest all the time.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

I just found a temporary solution myself.

It looks like the container doesn’t take the host’s /etc/resolv.conf into it. The container’s /etc/resolv.conf had no DNS server listed at all.

Since I manaully map it in docker-compose.yml the sever is back right away.

Still no idea why the container doesn’t respect the host one, though.

I am a novice and would like to know if it’s possible to set up a Plex server in DigitalOcean and if it’s fairly easy?

Thank you in advance

Submit an Answer