Question

Certbot auto renew error. Cannot bind to port 80 can install but how to get script to work?

Hello i installed certificate using this link

https://www.digitalocean.com/community/tutorials/how-to-use-certbot-standalone-mode-to-retrieve-let-s-encrypt-ssl-certificates,

it has an issue binding to port 80 so i had to turn of Apache to install it and then turned it back on. with the auto renew script it gets the same error, how do i get it to work properly with out needing to turn of apache each time?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

In order to issue your Let’s Encrypt SSL certificate, you need to make sure that your domain name is pointing to your server. This essentially means that your A record needs to match your server IP. This is how Let’s Encrypt validates your domain name.

Regards, Bobby