Question

Certbot doesn't list my URL? Wordpress

Hi, sorry, I have no idea what I’m doing… I have wordpress installed on ubuntu 18.04. Domain name works. I must’ve done something wrong though, because when I run certbot --apache in the terminal the only option is ‘www.root’. I’ve looked for a solution, like editing the apache config but I don’t know how to do that. 😩 Any ideas?

https://i.imgur.com/0EZzDW0.png


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @Kep0a,

Usually, certbos uses your Apache vhost files. Have you by any chance added the domain to your default vhost file?

Usually, you need to add a new file for your domain and add the desired settings there. If you are uncertain how to do so,I’ll recommend checking out the following DigitalOcean guide

https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04

It will help you out with properly setting a separate vhost file.

Regards, KFSys