Question

Certbot failed to renew on a domain I no longer use, and now my other two domains on the same droplet are no longer HTTPS

Several weeks ago, I was notified by certbot that one of my unused domains was no longer secure. But, I didn’t think this would affect my two remaining domains, by making them unsecure too, yet it did. So I tried to fix this.

First, I deleted the unused domain from digital ocean. Next, I used the certbot command,

sudo certbot delete

hoping to delete the unused domain from the list of my other certbot domains (I have one main domain, and one virtual host domain, and both need to be HTTPS). But after using

sudo certbot renew --dry-run

my two remaining domains are still no longer HTTPS, and, the domain I attempted to delete is STILL listed, even though it should have been deleted.

I saw this article, but only after I already did the above: https://www.digitalocean.com/community/questions/unable-to-delete-the-dns-of-a-domain-while-deleting-this-domain-it-says-it-would-prevent-the-let-s-encrypt-certificate-renewal

I also tried using the digital ocean control panel, https://docs.digitalocean.com/products/accounts/security/certificates/ to create a secure certificate for my main domain, and hopefully the other one too, but that didn’t work also. My two remaining domains are still no longer HTTPS secure.

So, is there anything else I can do now? Thank you.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, @diane

Would you mind sharing the exact output of the certbot command so that we can check the error messages?

Regards, Alex