change max upload size in php.ini

  • Posted September 27, 2014

My droplet has Centos 6.5 32 bit installed on it. I have installed zpanel. I wanted to importing a large mysql datatbase from phpmyadmin. So as I searched the internet I need to modify the php.ini file. When I enter the code /etc/php.ini, I get the following message “-bash: /etc/php.ini: Permission denied”. I’m signed in as “root”. Would somebody tell me what is the problem, and how to enable importing large databases (increase max upload size, max upload time, max packet etc.)

I guess I don’t need to tell you that I’n a noop (no experience but google)


I don’t know that much about zpanel, but what are you trying to edit /etc/php.ini with? The command line? A SFTP editor, or through something in zpanel?

I have edited php.ini with vi or nano editor as well as WinSCP hundreds of times without any problems. Definitely no permission denied.

If you do get the file edited make sure you restart apache/httpd after doing so if that is what you are using for the changes to take effect.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there!

In order to change the max upload size, you’ll have to edit a file in your server. The file is named ‘php.ini’ but it can be located in different paths, depending on the operating system and the web server installed. To get information about where your php.ini file(s) are, you can simply create a php script with the following code:


Access this script through your browser to find out where the loaded ini files are.

Once you know where the php.ini is, you should edit it using an editor like nano or vim. Find the directive upload_max_filesize and increase its value. After doing that, you’ll probably need to restart your web server.


You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:


You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of upload_max_filesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 200M

You also need to restart your web server in order the changes to take effect.

Hope that this helps! Regards, Alex

From the command line you can run:

php -i | grep "Loaded Configuration File”

This will tell you the location of the php.ini file you will need to edit.