Question

Change Roundcube's max number of uploads and max upload size

Posted December 13, 2015 3k views
UbuntuApachePHPEmailControl Panels

I’m trying to change the maximum number of uploads and the maximum upload size in Roundcube. According to the Googling, it should be just a matter of changing the php.ini settings. I’ve changed the settings in /etc/php5/apache2/php.ini (and /etc/php5/cli/php.ini to be sure). This should be the correct path and the settings are applied in phpinfo. I’ve used locate to find every php.ini on my server and changed the variables there. I’ve checked every Roundcube and Sentora config file I can find for some kind of hardcoded variable, and combed through the MySQL database to see if maybe it was set there.

I just can’t seem to figure out why this isn’t working. The default limit is way too low and I’d really like to increase it. Could anyone give some direction on why it’s not working?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

You need to give some more detailed information. Please post the edited section of the php.ini files and the config files you modified.

Hello all,

You can create a PHP info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be similar to this:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of upload_max_filesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally, you would like to have the following values:

upload_max_filesize = 64M

You also need to restart your web server in order for the changes to take effect.

Hope that this helps!
Regards,
Alex