Change session timeout while interacating over SSH connection

November 17, 2014 7.7k views

How to increase/disable session timeout while interacting with my droplet from terminal over a SSH connection ?

1 Answer

Which SSH client are you using? The easiest (and recommended) way to change this is to alter the polling rate on the client side.

If you happen to be using putty for Windows, you can change your polling under Connection. As show in this guide http://www.oneminuteinfo.com/2011/07/putty-session-times-out-too-fast.html.

You may also change it server side, as show here: https://docs.oseems.com/general/application/ssh/disable-timeout.

I would only recommend that you extend the timeout instead of removing it, as it may be a security risk if you leave yourself logged into a machine.

  • I am using the using the ssh-client from terminal on Mac OS X. Anyway the links that you pointed to helped me with the issue.
    I set the ServerAliveInterval for the ssh-client and "ClientAliveInterval" and "TCPKeepAlive" on the server. Now its working for me.

    Thanks a lot. Cheers !

  • That was the key! Thanks!

Have another answer? Share your knowledge.