Question

Changing port from 80 to 443 redirects site to index (SSL related)

Hi there, i am trying to install my SSL certificate and the problem seems to be that

As soon as the virtualhost port in /etc/apache2/sites-available/default-ssl.conf or 000-default.conf is changed from 80 to 443 (needed for SSL) my website gets directed to a index folder of the html

I am running Ubuntu 14.04 w/wordpress & apache

Any help whatsoever to solve this is appreciated

Here is what my 000-default.conf looks like

<VirtualHost *:443> ServerName prollagen.com SSLEngine on SSLCertificateFile /etc/ssl/key (redacted) SSLCertificateKeyFile /etc/ssl/key (redacted) SSLCertificateChainFile /etc/ssl/key (redacted) DocumentRoot /var/www/html

    <Directory /var/www/html/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
    </Directory>
    
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Instead To do a manually setup, i use Proxy Manager https://nginxproxymanager.com its a great tool.

hi blakeingram405 or this will help for any of you.

For eg: If you set a virtual host with 443 port and your site not working then you can add the same virtual host config and remove servername, serveralias and add in 000-default.conf file with <VirtualHost *:80>

For eg copy the same configuration and remove servername, serveralias, ssldetails and add in 000-default.conf .

<VirtualHost *:443> DocumentRoot “/var/www/html” ServerName prollagen.com ServerAlias *.prollagen.com SSLEngine On SSLCertificateFile /etc/ssl/key SSLCertificateKeyFile /etc/ssl/key SSLCertificateChainFile /etc/ssl/key

<Directory /var/www/html/> Options Indexes FollowSymLinks AllowOverride All Require all granted </Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined </VirtualHost>

The 000-default.conf should be as follows

<VirtualHost *:80> DocumentRoot “/var/www/html”

<Directory /var/www/html/> Options Indexes FollowSymLinks AllowOverride All Require all granted </Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined </VirtualHost>

So cloudflare was the problem! As with “Options -Indexes”, when placing - in front of indexes apache throws out an error stating “if an option has - or +, all other options must have the same”

What would another “option” be within 000-default?