Question

Changing upload size? Finding the right directory? Restarting?

Posted July 12, 2015 3.7k views
ApacheWordPress

So after reading multiple guides on how to change the upload limit for wordpress, I was not able to find the php.ini file in any of the common folders, I had to go to this location “/etc/php5/cli/php.ini”, eventually I found the uploadmaxfile_size and changed it to 10M. Now I tried restarting with multiple commands, and I keep on getting the “AH00558” error. I then found a fix for that error, but I’m still getting the same AH00558 error.

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

You still got a 2mb limit because you edited the php configuration for the CLI PHP. If you are running the apache webserver you need to edit /etc/php5/apache2/php.ini
Also check the max postsize.

Allright try to execute

apt-get remove php5*
apt-get install php5

And check again, please give a result when done.

I solved this by just adding the two command lines into a new php.ini file in my apache5 folder

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 200M

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex

Submit an Answer