Question

clear cache on Ruby on Rails on Ubuntu (nginx + unicorn)

  • Posted on June 30, 2014
  • komraAsked by komra

I set up a new Ruby on Rails on Ubuntu (nginx + unicorn) droplet. The only thing I did was change the html in the default home page (/home/rails/app/views/home/index.html.erb).

Now when I load and reload the home page at http://104.131.230.147/ it switches between the original home page and the new one. I have checked with others to see if the behavior is the same for them and it is.

I’ve tried rake tmp:cache:clear rake assets:clean

What other options are there?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have this same problem with Django+Ubuntu. I’m thankful that at least restarting gunicorn gets a temporary fix. I can’t seem to find any solution to this and I’m amazed that more people don’t have this problem.

Where is the caching coming from? Also, where is this “config.action_controller.perform_caching = false” change made?

I have also had problems with caching running Unicorn with multiple worker processes. If you’re using config.cache_store = :memory_store in your environments/production.rb that could be the issue. In this case it appears that the memory store is duplicated across the workers. Try switching settings to

config.action_controller.perform_caching = false

and see if the behavior stops. If so, you probably need to use a different caching strategy. See http://guides.rubyonrails.org/caching_with_rails.html#cache-stores

Are you restarting the unicorn server after changing the file? Run:

service unicorn restart

Also make sure that a copy of the page isn’t being cached in /home/rails/public/