clear cache on Ruby on Rails on Ubuntu (nginx + unicorn)

Posted June 30, 2014 23.1k views

I set up a new Ruby on Rails on Ubuntu (nginx + unicorn) droplet. The only thing I did was change the html in the default home page (/home/rails/app/views/home/index.html.erb).

Now when I load and reload the home page at it switches between the original home page and the new one. I have checked with others to see if the behavior is the same for them and it is.

I’ve tried
rake tmp:cache:clear
rake assets:clean

What other options are there?

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
4 answers

I tried the suggestions here:

Does anyone have experience with creating a droplet using this image? I am wondering if the image is broken.

Would it be better to set up a rails server starting with a straight Ubuntu 14.x Linux Distro image?

Are you restarting the unicorn server after changing the file? Run:

service unicorn restart

Also make sure that a copy of the page isn’t being cached in /home/rails/public/

  • Hi ,

    I did this one It is working good but if I am doing some more changes and then again and again I have to go in terminal and all the time I have to do service unicorn restart

    any other solution to do only one time restart and it will works proper ????


I have also had problems with caching running Unicorn with multiple worker processes. If you’re using
config.cache_store = :memory_store
in your environments/production.rb that could be the issue. In this case it appears that the memory store is duplicated across the workers. Try switching settings to

config.action_controller.perform_caching = false

and see if the behavior stops. If so, you probably need to use a different caching strategy. See

I have this same problem with Django+Ubuntu. I’m thankful that at least restarting gunicorn gets a temporary fix. I can’t seem to find any solution to this and I’m amazed that more people don’t have this problem.

Where is the caching coming from? Also, where is this “config.actioncontroller.performcaching = false” change made?