Question

Cloud Firewall too slow

Anyone else experiencing slowness when enabling cloud firewall even when using private network? I spawned up a MySQL instance droplet with another droplet running as a client. I added a tag to the DB and enabled the Cloud Firewall to that DB tag, client connections starts to intermittently timeout. I know the configuration is correct because after several retries it can pass through. Disabling the firewall (read: removing the tag) solves the lag.

Anyone experienced this? Anything that I might be missing? As a workaround, I used internal firewall UFW.

Subscribe
Share

This would be disconcerting. Is there a team testing this over at DO, I would imagine so, if not there should be.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I was just experiencing this same issue with mysql + private networked droplets. It turns out the problem was that mysql by default is attempting to resolve the DNS of inbound connections, which will fail under active cloud firewalls because the TCP/UDP port for DNS queries is blocked (unless explicitly allowed).

To resolve this you can either:

  • Enable the TCP/UDP port 53 (DNS queries)

or

  • Disable name resolution with the following line in your mysql configuration by adding the following line:
skip-name-resolve