Question

Cloud9 couldn't connect to SSH server

Hi, i’m using Cloud9 IDE and trying to create a workspace with Digital Ocean, i’ve followed every step on this video, https://www.youtube.com/watch?v=xld1JXd70aY but at about 1:25, after i’ve entered the hostname of the droplet and username as root, i click Create workspace and this error pops up:

Cloud9 couldn’t connect to SSH server root@xxx.xx.x.xx

The droplet i created is Ubuntu Ruby on Rails on 14.04, i’ve tried many things, made sure i added the SSH key to digital ocean, changed username to rails, changed port to 80, i can even access the droplet console and changed password as the email suggests etc but still no luck. What other things could be causing this error?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Probably got something wrong in the setup with the permissions. You can find and post more information at your ssh log

/var/log/auth.log