Cloud9 couldn't connect to SSH server

Posted August 17, 2015 4.8k views
Ruby on RailsUbuntuDigitalOcean

Hi, i’m using Cloud9 IDE and trying to create a workspace with Digital Ocean, i’ve followed every step on this video, but at about 1:25, after i’ve entered the hostname of the droplet and username as root, i click Create workspace and this error pops up:

Cloud9 couldn’t connect to SSH server root@xxx.xx.x.xx

The droplet i created is Ubuntu Ruby on Rails on 14.04, i’ve tried many things, made sure i added the SSH key to digital ocean, changed username to rails, changed port to 80, i can even access the droplet console and changed password as the email suggests etc but still no luck. What other things could be causing this error?

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Probably got something wrong in the setup with the permissions. You can find and post more information at your ssh log