Question

Cloudflare breaks my website

So I got a domain (from google domains) and set it up and it worked fine, went to my website here on my droplet. I decided to add cloudflare to protect it, set it up and then it said cloudflare is now protecting your website. It has been over 24 hours, for some reason when I go to the domain now it just says Error 521: The web server is down, and even when I go to the droplets direct ip it cant display the web page, It only happens when I add cloudflare and I have tried restarting the webpage and all, its definitely not the server being down. Im stumped…

Update: It only does it when I add https now… how do I fix this?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

I believe that the fastest solution would be to set your SSL to Flexible via your Cloudflare control panel.

For a more secure solution you could set up an end-to-end SSL by following the steps here from the official Cloudflare documentation:

https://support.cloudflare.com/hc/en-us/articles/200170416

Let me know how it goes! Regards, Bobby