Question

CNAME record not propagating

Posted March 13, 2021 321 views
DNS

My domain registrar is NameCheap and I have their DNS pointing at Digital Ocean. I then have all my standard DNS entries in Digital Ocean. I am attempting to set up a custom domain for Google Firebase Authentication which requires 2 TXT and 2 CNAME records to be entered into my DNS. I have done so and have waited several days, multiple times and only the TXT records can be detected. The CNAME records will not propagate. Does anyone have any thoughts?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hello @dlvanmullen

Can you please confirm that you’re using the DigitalOcean nameservers for your domain name? The name servers are ns1.digitalocean.com, ns2.digitalocean.com, and ns3.digitalocean.com

What you can do is to make sure the CNAME is entered correctly. On DigitalOcean, CNAME records have the following fields.

  • HOSTNAME, which should be set to the subdomain prefix for the new alias you want to create.
  • IS AN ALIAS OF, which should be set to the hostname where the alias should point. For the alias to work, the hostname must have an A record or be handled by a wildcard A record. This can be:
  • The apex domain (@). To map a apex domain, like example.com, enter the @ symbol.
  • A *subdomain *(e.g. site.example.com).

You can also check our docs on how to setup a CNAME record for your domain name here:

https://www.digitalocean.com/docs/networking/dns/how-to/manage-records/#cname-records

Hope that this helps!
Regards,
Alex