Question

Command 'ghost' not found in recent Droplet install

I have a one-click Ghost install up and running smoothly on my domain, however, the terminal for my droplet is not allowing me to run any ghost commands. When I switch to the ghost-mgr account, I get the message that “Command ‘ghost’ not found, did you mean…”

NOW, because I did not read the fine print of the terminal messages when I first logged in, I tried to install the ghost-cli manually via npm. As I was doing this I tried to abort once I read the message, but now I feel like I have somehow really screwed up the ghost-cli tool.

Any ideas? Any way to simply uninstall the cli and reinstall it? What’s my best path forward here? Thanks!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @fieldnoise,

According to ghost’s documentation, you can do the following:

# On a production server using a non-root user:
sudo npm install -g ghost-cli@latest

It should be enough. Don’t forget to do it with the user ghost-mgr.

Additionally, here is the whole docs page;

https://ghost.org/docs/ghost-cli/