Question

Configure dedicated SSL certificate from Cloudflare on my droplet

I recently bought a dedicated ssl certificate with cloudflare. https://www.cloudflare.com/ssl/dedicated-certificates/

The certificate is active, however, the result test is as it follows:

curl -sv -o /dev/null https://www.mysite.com/ --resolve www.mysite.com:443:my.ip.num.ber
* Added www.mysite.com:443:my.ip.num.ber to DNS cache
* Hostname www.mysite.com was found in DNS cache
*   Trying my.ip.num.ber...
* TCP_NODELAY set
* Connection failed
* connect to my.ip.num.ber port 443 failed: Operation timed out
* Failed to connect to www.mysite.com port 443: Operation timed out
* Closing connection 0

From cloudflare recommend me to open port 443 at my origin webserver/droplet. How can i do this? do i need anything else to be done?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

this is my actual configuration,

<VirtualHost my.droplet.ip.num.ber:80>

        ServerAdmin mymail@gmail.com

        DocumentRoot /var/www/mysite/

        ServerName mysite.com

        ServerAlias www.mysite.com

        ErrorLog /var/www/error.log

        CustomLog ${APACHE_LOG_DIR}/access.log combined

        <Directory /var/www/mysite/>
                Options Indexes FollowSymLinks
                AllowOverride All
                Order allow,deny
                Allow from all
                Require all granted
        </Directory>

</VirtualHost>

How can i use both ports?

Hi @musicos

Since you’re running Ubuntu, I’m guessing you might have setup the UFW firewall, so run this command to see if it’s active and allowing port 443:

sudo ufw status

But I don’t know how the dedicated certificate works on CloudFlare. I’m not sure if it’s required to have encrypted traffic between CloudFlare and your server - if it is, then you need to put the certificate on your web server as well. You should be able to see more in the control panel on CloudFlare - it should tell if it has connectivity with your server or not.