Configure Helpy.io to use IMAP and Gmai

March 7, 2019 585 views
Automated Setups Ubuntu 18.04

Hello,

Congrats for the new marketplace. Makes it easy for people like me to install helpful tools like Helpy.
Unfortunately, IMAP do not seem to be functional out-of-the-box.

In the Settings: Email of Helpy, it seem a command is required to activate IMAP:
IMAP will require run ‘rake helpy:mailman’. Also changes will require a restart of the rake task

How do I do that? In the console?
Console tells me:

rake aborted!
No Rakefile found

Thank you

8 Answers

Hey friend!

Thank you so much for taking the time to ask this. Please do not take me as saying that this is the wrong place, as I want this Q&A to feature as many questions and answers as possible. However, I want to take the opportunity to share that we have added a support path for the images in our marketplace. If you go to the Create Droplet page and then click on the Marketplace tab, there is a Details link next to the image. From there you can find support information for that image. This is the information from the Helpy image:

Supported by: Helpy.io, LLC
Hours: 9am-5pm, Mountain Time
Support URL: https://support.helpy.io 
Support Email: hello@helpy.io 

I, myself, do not know the answer to your question. Someone browsing here may, and the Helpy team is also welcome to join in here and answer. However, you may receive a faster answer through that support path. If you get an answer that requires action on your part, I would love it if you took a moment to post it here.

Jarland

Hey-

Scott here from Helpy. The trick is to make sure you are running the command with the correct user account. The one-click image runs everything under a user named ‘deploy’, so you should either switch to that user with

su deploy
cd ~/helpy
bundle exec rake helpy:mailman

or

ssh root@your.ip
rsync --archive --chown=deploy:deploy ~/.ssh /home/deploy

then go ahead and access the droplet using the deploy user and then execute the command in the first example.

Scott

  • Unfortunately this does not work either.

    root@helpy-s-1vcpu-2gb-lon1-01:~# su deploy
    deploy@helpy-s-1vcpu-2gb-lon1-01:/root$ cd ~/helpy
    deploy@helpy-s-1vcpu-2gb-lon1-01:~/helpy$ bundle exec rake helpy:mailman
    
    Command 'bundle' not found, but can be installed with:
    
    sudo snap install ruby          # version 2.6.2, or
    sudo apt  install ruby-bundler
    
    See 'snap info ruby' for additional versions.
    
    deploy@helpy-s-1vcpu-2gb-lon1-01:~/helpy$ ./bin/bundle exec rake helpy:mailman
    Traceback (most recent call last):
            2: from ./bin/bundle:3:in `<main>'
            1: from /usr/lib/ruby/2.5.0/rubygems.rb:263:in `bin_path'
    /usr/lib/ruby/2.5.0/rubygems.rb:289:in `find_spec_for_exe': Could not find 'bundler' (1.17.1) required by your /home/deploy/helpy/Gemfile.lock. (Gem::GemNotFoundException)
    To update to the lastest version installed on your system, run `bundle update --bundler`.
    To install the missing version, run `gem install bundler:1.17.1`
    
    

I’m the OP and it didnt work either. Can’t even make the SMTP send emails in combination with SENGRID.

We decided to go another route. Good luck with this project.

You must execute source /home/deploy/.rvm/scripts/rvm and then bundle exec rake helpy:mailman

I’m getting PG::ConnectionBad: fe_sendauth: no password supplied and it’s not true as databse.yml ENV is set properly…

Any ideas?

Thanks for that answer @mladenjordanov I have seen that PG error most commonly if the current logged in user does not match the username being used to connect to Postgres. There is a setting for Postgres so you can disable this check, although I don’t remember the name of the setting.

@scottmiller Can you check bellow attached, I managed to get mailman to fetch new messages but tickets aren’t created.

“`deploy@help:~/helpy$ bundle exec rake helpy:mailman mail_interval=60
I, [2019-04-04T08:04:24.921698 #19825] INFO – : Mailman v0.7.3 started
I, [2019-04-04T08:04:24.921942 #19825] INFO – : IMAP receiver enabled (xxx@xxxxx@mail.xxxxxx).
I, [2019-04-04T08:04:24.970100 #19825] INFO – : Polling enabled. Checking every 60 seconds.
I, [2019-04-04T08:04:26.649965 #19825] INFO – : Got new message from ’xxxx@gmail.com’ with subject ’Re: [xxxxx Support] #4-xxxxx’.

<:connectionbad: no password supplied fe_sendauth:="">

I, [2019-04-04T08:05:28.683623 #19825] INFO – : Got new message from ’zzzzzz@gmail.com’ with subject ‘test’.

<:connectionbad: no password supplied fe_sendauth:="">

code”`

Any advice?

Hi @mladenjordanov sorry for the delay in response. This looks like a Postgres login problem. In the default configuration, the droplet expects the postgres username to be ‘deploy’ . Are you using a different user? If so, there is an option in Postgres.conf that allows a different username from the ubuntu user that is logged in. If you find and change this, you should be all set.

@scottmiller thank you for getting back to me, can you please share sample configuration for mailman.cfg as /home/deploy/helpy/mailman.cfg is empty after initial config.

Have another answer? Share your knowledge.