Question

Configure Send Mail (MX, TXT?)

Posted August 7, 2013 7.9k views
Hi, I've read this document: https://www.digitalocean.com/community/articles/how-to-install-postfix-on-centos-6 and I've done everything as same. But now, I should, configure DNS options? this is my dns page: http://p1308.hizliresim.com/1d/7/r806h.png what should I do now? (for my sending mail not to go spam) Think that my IP address is : 10.10.10.10 and please, tell me step by step to make perfect send mail. (I've tried to make it with gmail mx, but when I did this, my mails have gone to spam) I need your help and please, explain with an example

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
6 answers
edit: hmmm.

my server has 4 virtual servers. and one of them connected with ip address. and others, with domain.
for example when I connect the IP address www/main/ gets my screen.

when i type xxx.com www/xxx/ directory gets to my screen.

and, when i type mail.xxx.com www/main/ directory opens again?
I think problem is this, but how can I solve this prob?
by Keshav Pareek
Here we'll show you how to create a SPF record for your domain with Google Apps.
Try running this command:

echo test | mail -s "test" your@emailaddress.com
. Do you receive the email?
yeah i received but it has gone to the "spam mail" box.
Take a look at the articles Pablo linked above. Setting up an SPF record should help prevent your emails from going straight to the spambox.
This is a slight digression but, it turns out that my problem was using my client's domain name for hostname. When I changed it to one of my proven personal domains, it worked great. I assume that they have an SPF or something. In any case, if your mail.log says the messages was accepted, try changing the hostname.
Submit an Answer