Question

Configuring Nginx to forward PHP requests

I’m getting this error when restarting nginx:

“fastcgi_pass” directive is not allowed here in /etc/nginx/sites-enabled/wordpress:65

Any help would be appreciated.

I’m trying to use Nginx and install wordpress instead of the usual. Is that wise?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I don’t understand – is it working now that you have done a fresh LEMP install?

Hi Kamal, I managed to solve the problem but since I’ve done a fresh install of LEMP and would like to know with the virtual host file, can I just copy and paste the whole of the update after getting rid of what’s in there to start with, if you get my lingo.:)

Please pastebin the contents of /etc/nginx/sites-enabled/wordpress – http://pastie.org