Configuring sub domain ERR_NAME_NOT_RESOLVED?

November 15, 2016 59 views
DNS API Ubuntu 16.04

Hi there.

I still don't really understand DNS and domains, especially not when using sub-domains. I hope some one can help me!

So I'm building an API (just a school project nothing to big). I want to serve my data securely so I need an SSL cert., I bought a domain from my favorite hosting provider, similar to my name, so that I can drop my portfolio on there for later on.

I don't make use of my full domain at all, just a subdomain for my api, which is currently on my droplet at /var/www/dorsia. I tried configuring my DNS and nameservers on both ends (as well from Digitalocean as from my hosting provider), but when I visit my subdomain it gives me ERRNAMENOT_RESOLVED. Also my full domain gives me the same, which first returned the page from my hosting provider that it is reserved by me.

I'll post the settings here.

DigitalOcean settings (note: this is for subdomain.domain.com, not domain.com):

http://imgur.com/prUHKPA

Zone file:

$ORIGIN dorsia.fabiantjoeaon.com.
$TTL 1800
dorsia.fabiantjoeaon.com. IN SOA ns1.digitalocean.com. hostmaster.dorsia.fabiantjoeaon.com. 1479132520 10800 3600 604800 1800
dorsia.fabiantjoeaon.com. 1800 IN NS ns1.digitalocean.com.
dorsia.fabiantjoeaon.com. 1800 IN NS ns2.digitalocean.com.
dorsia.fabiantjoeaon.com. 1800 IN NS ns3.digitalocean.com.
dorsia.dorsia.fabiantjoeaon.com. 1800 IN A 45.55.184.33
www.dorsia.fabiantjoeaon.com. 1800 IN CNAME dorsia.fabiantjoeaon.com.
*.dorsia.fabiantjoeaon.com. 1800 IN CNAME dorsia.fabiantjoeaon.com.

And lastly, the settings from my hosting provider:

http://imgur.com/a/6hX8M

As this is my first time doing this, I'm pretty sure I did something wrong.
Could someone please help me out :(?

1 Answer

Looking over your configuration two things jump out at me:

1.) If you set your domain's DNS to our nameservers the other records with your registrar are not used.

2.) By setting the DNS servers for your domain to ns1/3.digitalocean.com you will then need to create a record for your domain itself, not the subdomain and create your subdomain record under that. If the zone you showed from your DO configuration is for dorsia.fabiantjoeaon.com you will have created dorsia.dorsia.fabiantjoeaon.com instead of what you intended.

It does appear that your subdomain is now working correctly, can you share what steps you took to resolve the problem?

Have another answer? Share your knowledge.