Question

confused about how DNS is setup

  • Posted on December 11, 2014
  • kzuanichAsked by kzuanich

I hope someone can help me.

For some reason when I go to http://www.mywebsite.com I am getting something different then when I go to http://mywebsite.com

My DNS records are: A | @ | ##myIP## A | test | ##myIP## CNAME | * | mywebsite.com CNAME | www | mywebsite.com

I am so confused. I feel like it has something to do with poor configuration of test.mywebsite.com which is a url I set up for testing.

Hopefully someone can help!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @kzuanich:

I found the problem! In my conf file, I had:

ServerName www.mywebsite.com

but I changed it to:

ServerName mywebsite.com

and restarted apache and now everything seems to work fine.

:)

View the original comment