seabey
By:
seabey

Connect Error (2003) Can't connect to MySQL Server on '' (111)

October 7, 2014 46.7k views

Ubuntu 14.04 x32.

Installed php, phpmyadmin, apache, mysql.

Created database, upload my website files and I'm getting this error message:

Connect Error (2003) Can't connect to MySQL server on 'myipaddress' (111)

I tried these solutions:

1) In etc>mysql>my.cnf change these line:
secure.bind-address=127.0.0.1
to
secure.bind-address=myipaddress
Didn't work.

2) mysql> GRANT ALL ON mydbname.* TO root@'myipaddress'
-> IDENTIFIED BY 'mymysqlpassword';

It did'nt work, too.

What can i do sometimes?

1 comment
5 Answers

Is MySQL running?

sudo ps wwaux | grep -i sql

If that does not output anything, try starting the MySQL service:

sudo service mysql start

Also, what hostname/port is MySQL listening on?

sudo netstat -plutn | grep -i sql
  • This is first query's output:

    sudo ps wwaux | grep -i sql

    mysql 17375 0.1 7.3 327804 37084 ? Ssl 12:21 0:00 /usr/sbin/mysq d
    root 17682 0.0 0.1 4680 836 pts/0 S+ 12:27 0:00 grep --color=auto -i sql

    This is last query's output:

    sudo netstat -plutn | grep -i sql

    tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 17375/mysqld

  • Ok, so MySQL is running but is listening on the loopback interface (127.0.0.1) and not eth0 (your droplet's public IP address). Set secure.bind-address back to 127.0.0.1 so that MySQL doesn't listen on the public IP address once it is restarted and use $host = '127.0.0.1';. Does that work?

  • It's probably working now. Thank you so much. I love Israel.

in my system second query is not running

The Remote desktop feature is disabled by default in Windows 10, to explore and enjoy these Remote desktop services and must allow remote access to the target machine in order to establish the connection. To turn On windows remote desktop connection

I have the same error but i get this when i entered

sudo ps wwaux | grep -i sql
root 14874 0.0 0.0 12944 936 pts/0 S+ 21:42 0:00 grep --color=auto -i sql
what should i do?

Have another answer? Share your knowledge.