Connect Error (2003) Can't connect to MySQL Server on '' (111)

Posted October 7, 2014 111.9k views

Ubuntu 14.04 x32.

Installed php, phpmyadmin, apache, mysql.

Created database, upload my website files and I’m getting this error message:

Connect Error (2003) Can’t connect to MySQL server on ‘myipaddress’ (111)

I tried these solutions:

1) In etc>mysql>my.cnf change these line:
Didn’t work.

2) mysql> GRANT ALL ON mydbname.* TO root@'myipaddress’
-> IDENTIFIED BY 'mymysqlpassword’;

It did'nt work, too.

What can i do sometimes?

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
6 answers

Is MySQL running?

sudo ps wwaux | grep -i sql

If that does not output anything, try starting the MySQL service:

sudo service mysql start

Also, what hostname/port is MySQL listening on?

sudo netstat -plutn | grep -i sql
  • This is first query’s output:

    sudo ps wwaux | grep -i sql

    mysql 17375 0.1 7.3 327804 37084 ? Ssl 12:21 0:00 /usr/sbin/mysq d
    root 17682 0.0 0.1 4680 836 pts/0 S+ 12:27 0:00 grep –color=auto -i sql

    This is last query’s output:

    sudo netstat -plutn | grep -i sql

    tcp 0 0* LISTEN 17375/mysqld

  • Ok, so MySQL is running but is listening on the loopback interface ( and not eth0 (your droplet’s public IP address). Set secure.bind-address back to so that MySQL doesn’t listen on the public IP address once it is restarted and use $host = '';. Does that work?

  • It’s probably working now. Thank you so much. I love Israel.

Here my connection codes:


in my system second query is not running

I have the same error but i get this when i entered

sudo ps wwaux | grep -i sql
root 14874 0.0 0.0 12944 936 pts/0 S+ 21:42 0:00 grep –color=auto -i sql
what should i do?

after changing the bind address and granting permission, restart mysql

$sudo service mysql restart