Question

Connect phpmyadmin to mysql cluster

Hi,

I have phpmyadmin installed on a droplet (not in same VPC), which I’m trying to setup to connect to the DB cluster which I have created. The server is allowed to connect, and I’m using MySQL 5.x legacy connection for the user I’m trying to connect with.

It works great to connect from the server it self, but its refusing from phpmyadmin. The error I’m getting is: The server requested authentication method unknown to the client [caching_sha2_password]

Despite that I have set for that user to use legacy MySQL 5.x, it still somehow throwing MySQL 8.x error because caching_sha2_password is used there.

I have also tried with: alter user ‘nookie’@‘%’ identified with mysql_native_password by ‘mypassword’; however I’m still getting this error.

So the question why is this not being picked up by the cluster, that i’m trying to connect with phpmyadmin from a remote server to MySQL 5 legacy connection. Is there any other settings that I can make?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @nookie,

I know it’s weird to ask but which PHP version are you using? I think these issues if not resolved by what you mentioned with allowing the user in MySQL to be identified with a mysql_native_password can be resolved by using PHP 7.3 or 7.4.

Okay,

I have found the solution. It was simply to upgrade to version PHP7.3 minimum. For those running on debian 9, here is a guide: https://www.jesusamieiro.com/install-php-7-3-on-debian-9/

Thanks a lot and good luck everyone!