So I’m trying to access to my server using my iOS device trough an App called Prompt 2, it’s connect via ssh.

My data in prompt is:

SHH | IP of the server
Port | 22
Username | root
Password | The password

the error I get is: “Credentials were not accepted by the server”

I tried with another VPS provider and worked with no problems. So I asume is something with Digital Ocean.

Anyone using this App was able to connect via ssh to Digital Ocean?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

@camilopereirat

When you create a droplet with your public key the droplet is configured to accept public key authentication and refuse password authentication, I think this is your problem to make sure open this file /etc/ssh/sshd_config and make sure that PasswordAuthentication is set to yes not no, then restart ssh with this command sudo servcie ssh restart

Hope this helps

Submit an Answer