Connecting to Droplet via FileZilla

Posted August 9, 2017 4.8k views
SecurityDigitalOceanUbuntu 16.04

I have never had this much trouble connect to a website…I confess I’m a newbie to DO - their support has been rather “catty” in offering assistance…but here’s the details of my adventure:

I’ve created my keys per these instructions -

I’ve set up FileZilla according to the instructions here -

09:49:22 Status: Connecting to…
09:49:22 Response: fzSftp started, protocolversion=8
09:49:22 Command: keyfile “/Users/Donna/.ssh/id
09:49:22 Command: open “root@” 22
09:49:23 Error: Disconnected: No supported authentication methods available (server sent: publickey)
09:49:23 Error: Could not connect to server

After many attempts to add my public key to an existing droplet - via my Terminal when I try command - ssh root@

I keep getting:
Permission denied (publickey)

I’ve added my public key via DO Console to the ~/.ssh/authorized_keys file. I’ve restarted the server using “sudo service ssh restart”

Any support would so be appreciated!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

The error message that you are getting:

Permission denied (publickey)

Indicates that your public key and private key do not match. If you were trying to use the DO console to add the public key then there is most likely a typo.

If you haven’t yet worked on the server then the easiest way around this is to:

  1. Save your public key into your DigitalOcean account at: Account -> Setting -> Security -> SSH Keys
  2. Destroy your current droplet: Droplets -> Destroy -> Destroy
  3. Create a new droplet and select the public key you saved at 1. to be loaded on to it. This option is only available for droplets created after you save your SSH key into your DititalOcean account.

Doing this will delete all data on your existing droplet but it you haven’t yet managed to log it that shouldn’t be a problem.