Question

Connection closed by remote host after long duration

Hi guys, quick question.

I was running a web-scraper script overnight on my DigitalOcean droplet. The script takes a while to run because I’ve added a time delay within the loop. After about 1-2 hours, I got a message: “connection to [ip address]_ closed by remote host”.

Is there any way to set the host to not terminate the connection?

Regards, Eric


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

Are you trying to SSH using your SSH key or just with a password?

Note that by default on most Linux distributions password authentication is disabled.

If you don’t have your SSH key on file, you could enable password authentication by following the steps here:

https://www.digitalocean.com/docs/droplets/resources/lost-ssh-key/

After that, you could use PuTTY and authenticate with a password.

Hope that this helps! Regards, Alex

Did you run the script through SSH terminal? If yes, then just a tiny hiccup anywhere from your computer to the server, might reset the secure tunnel. If you want to run something all night long, then you’re better of by letting the server handle it - if that’s not possible, because how the script is created, then you can run it through the Console, which you can access through the DigitalOcean control panel.