Connection issues?

Posted July 8, 2013 16.8k views
How come at times I cannot connect to my server? I have a LEMP stack configured and often times throughout the day, I'll try to connect to the site only for it not to connect. During these times I cannot access the server through putty, or FTP. The "downtimes" could last upwards of 2+ minutes some times. Is something configured improperly or is this another issue?
1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

27 answers

Same here. Experiencing it now and this is the really first time that I’m having a real issue on DO. What’s weird is that I have several VPS all in the same location (Singapore) but only my Rails VPS (created from 1-click app) is down. When I’m trying to ping it, it shows:

PING 188.166.X.X (188.166.X.X): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Request timeout for icmp_seq 6
Request timeout for icmp_seq 7
Request timeout for icmp_seq 8
Request timeout for icmp_seq 9
Request timeout for icmp_seq 10

We are planning to use DO for some of our production apps and this issue is scaring the s**t out of me. Has anyone find a way to fix it and keep it that way?

Please provide a traceroute or mtr to your droplet in a support ticket if you experience this again, it will help us identify the cause of your droplet's downtime better. Thanks!
... I cannot access the server through putty, or FTP."

What kind of error message(s) do you get?
The error message I get from putty is "connection timed out". When trying to connect to the website hosted on the droplet I get "Google chrome could not connect to".

It's in the NY region. Next time I see it happening, I'll do a traceroute and make a ticket.
I am experiencing this problem as well and it seems to be due to some kind of standby feature in either KVM or the network equipment (the droplet is located in ams1). I eventually worked around the problem by running "ping -c 1" every 5 minutes. I first tried simply making some disk IO happen every 5 minutes but this did not solve the problem.
If you want to reproduce the problem, try to do the following:

1. Create a 512 or 1 GB droplet (any droplet will probably do)
2. Select Ubuntu 12.04 x32 (guess it will happen with other images as well though I haven't tested that)
3. Ping the droplet 1-3 times once it is ready (you should get a response immediately)
4. Wait 20 minutes before pinging it again (you should now get timeout / no response)
Dan, I was not able to reproduce this. I've created a 512MB droplet in NY with Ubuntu 12.04 x32 as the base image. I was able to ping it after 20 minutes.
Kamal, I will try to trigger the problem using my current droplet. I'll post a screenshot in about an hour.
Strange. I can't seem to reproduce it with a 20 minutes delay. I'll try to let it idle for 2 hours to see if it's simply a matter of waiting long enough. I'll get back to you later.
I am no longer able to reproduce the problem. I could do it multiple times a few days ago but either you guys fixed the issue or it was simply a network problem somewhere (which lasted for more than a day). I have now removed the ping command from crontab and then I'll see if it happens again the next time I need to access the server.
Kamal, by waiting a few more hours, this happened:

This happens a lot without the "ping -c 1" solution. Also, I verify each time that it's not my own connection that suffers from instability.
Kama, perhaps this is related?
I had it happen to me again today. I did a trace route and nothing looked out of the ordinary. I'm glad (sad?) that someone else is having the same issues and able to give a temporary work around.
Dan, can you please open up a support ticket? Please make sure you mention the affected droplet.

Kamal and tylodonnell, I've opened up a ticket so let's see if the problem can be solved. I'll report back here once I know more.
I get the same problem. I am submitting a ticket as well.
I have noticed the same thing. When I get to work in the morning (14:00 to 15:00 AM UTC) I ssh to my Droplet. (512 / Ubuntu 12.04 x64 in nyc1). Two mornings this week the connection attempt timed out. I started a traceroute, it completed successfully. I tried to ssh again and connected. The same problem happened when I tried to ssh from home tonight. I wondered if the host were sleeping or swapped out or something like that.

I do have another problem where ssh connections hang and disconnect sometimes never and sometimes several times a day (about a dozen disconnects in a few hours tonight). It happens from work (ipv4 only) and home where I have tried using both ipv4 and Hurricane Electric ipv6 tunnels.
Chad, the SSH disconnects/freezes are mostly caused by the same problem. You can prevent most of it by making your SSH client send keepalive packets every 2-5 mins. You can also use my PING solution until DO fixes the underlying problem. However, the solution is not perfect as you may still experience the problem from time to time.
Dan, how often do you run the ping fix for this? I have a cron job set for every 5 minutes to ping the gateway of my droplet, but that doesn't seem to make it any better.

It's very frustration having my website offline throughout the day.
Hi, have this problem as well with one of my droplets. The droplet is running Arch and is located in ams1. Now and then it just gets unresponsive. Pinging the host makes it respond again. I've been in contact with support which suggested that i should make a snapshot of my droplet, and then re-create it => hopefully moving it to a new hypervisor. Haven't tried that yet, but i will! :)
The problem should have fixed during the emergency network maintenance (core routers have been updated). I will try to remove the ping command from crontab and see if this is really the case.

Tyler, in case the problem still exists, then ping every 5 minutes instead.
I have been running "ping" inside a detached "screen -R" for a while so I am pinging every second. I have not seen the problem since I started pinging. Of course there was also the maintenance. I just stopped the ping and will see how things do now.

--- ping statistics ---
1018863 packets transmitted, 1018078 received, +566 errors, 0% packet loss, time 1018926203ms
rtt min/avg/max/mdev = 0.217/1.488/5376.771/20.170 ms, pipe 6
I have the same problem, for me it's much worser. it timeous almost every 10 min. I'm on osx, so it's just freezes. all i can do is close terminal window. This happends only in AMS datacenter.. with ubuntu and debian and centos.
@holms: Please open up a support ticket with a traceroute to your droplet.

Is there any resolution to this problem ?

I see it was reported 2 years back and even now I am facing a similar problem without any anomaly at the server.

My server just stops to respond sporadically anytime in the day for 10 odd minutes which is very frustrating for my customers.

Could DO guys suggests a fool proof way to protect this from happening ?

Please suggest asap.


I have a related issue - i have submitted a ticket.

I seem to have the same issue. My server seems to drop off the internet every 1-3 days. This causes e.g. all my IRC-connections to drop off simultaneously. My droplet resides in Amsterdam.

Submit an Answer