Connection not private error after installing Let's Encrypt

January 21, 2017 4.7k views
Apache Let's Encrypt Ubuntu

Hey guys,

Maybe someone could help me here because I'm lost.
So I followed DigitalOcean's tutorials for configuring my droplet. Installing apache, mysql, etc. At some point there was this tutorial for installing a SSL self-signed certificate. I installed that one too. At some point I found about Let's Encrypt and wanted to give it a try since the self-signed SSL wasn't doing anything, I guess something was wrong although there were no "Your connection is not private" errors. After installing Let's Encrypt I keep getting the "Your connection is not private" error and don't know what to do. I googled the problem but can't seem to find a solution to this and make the "https://" working. Any ideas?

Thanks in advance!

P.S. although I can find my way around in Ubuntu I'm not a power user so please be kind to me :)

4 Answers

[Later edit]

Since it was a new droplet and didn't had anything on it I just destroyed it and created another one. Although I had to go through the tutorials one more time I'm happy it solved the problem.

@stefun can you post here your solution which made it work for you. I am facing exactly this issue. I have installed Letsencrypt SSL following DigitalOcean tutorial. I added domain.com and www.domain.com

but now, when i access something inside www.domain.com/dev/index.php it says "Your connection is not private"

I thought I have installed lets encrypt cert on all domain options.

Kindly can you guide what is wrong I have done from this tutorial: https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-16-04

by Erika Heidi
This tutorial will show you how to set up a free TLS/SSL certificate from Let’s Encrypt on a Ubuntu 16.04 server running Apache as web server. TLS certificates are used within web servers to encrypt the traffic between server and client, providing extra security for users accessing your application.

Here is how to fix Your Connection is Not Private Error In Chrome
One of the main reasons behind such an error may be the wrong date and time settings. The SSL might fail to fetch data from the server when an inaccurate date is provided. To change them, go to Date and Time under Settings in your system, and choose the option Set Time Automatically. This helps in securing loading of data.
Slide the bar below Set Time Automatically to turn it on.This lets the system to fetch time directly from the network, thus providing accurate measures.
Source:- [ http://merabheja.com/connection-not-private-error-in-chrome/](http://)

Hi, we created a new droplet with centos 7

Then we have created the virtual host successfully following this tutorial: https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-centos-7
Domain is pointing successfully to new virtual host folder.

The virtual host DocumentRoot is pointing to (/var/www/mydomain.com/public_html) folder, we restart apache service after create it, but never worked, we have setting in httpd.conf file, DocumentRoot pointing to the apache default one (/var/www/html); and the domain is loading this last folder content.

Finally we created the SSL certificate successfully following this tutorial, but it does not work, Check:
https://www.ssllabs.com returns Alternative names - INVALID and NOT Trusted
When we create the certificate we get a successful response, but certificate does not work.

What must we do to make the certificate to work?

best regards

by Josh Barnett
The Apache web server is extremely powerful and flexible, which is why it's the most popular way of serving web content. Apache can host multiple domains or interfaces on one server by splitting sites into separate virtual hosts. In this guide, we will walk you through how to set up Apache virtual hosts on a CentOS 7 VPS.
Have another answer? Share your knowledge.